Home » » Cara Membuat Transparent Web Proxy Mikrotik kang

Cara Membuat Transparent Web Proxy Mikrotik kang

Written By Muin wijaya on Monday, January 14, 2013 | 1/14/2013

Apa itu proxy? Proxy pada umumnya berfungsi untuk menyimpan cache web yang berasal dari url sebuah web. Apabila sebuah LAN menggunakan proxy untuk berhubungan dengan internet, maka seketika itu pula browser client mengakses url web maka akan mengambil request tersebut di proxy server, jika data web belum tersedia dalam proxy maka proxy akan mengambil langsung dari web bersangkutan.
Kali ini saya sedikit membahas bagaimana Cara Membuat Transparent Web Proxy Mikrotik. Selain management bandwidth mikrotik juga dilengkapi dengan proxy, dan hasilnya request terhadap web atau url tertentu akan terasa lebih cepat apabila client meminta dengan alamat web yang sama dan proxy menyediakan tanpa harus meminta langsung ke internet.

Bagaimana cara mengkonfigurasi proxy di mesin mikrotik? berikut langkah-langkahnya :
  1. Login ke mikrotik denga username dan password mikrotik sobat.
  2. Dalam hal ini saya mengetikkan perintah melalui console mikrotik karena lebih mudah dan cepat

    IP Proxy :
    /ip proxy set enabled=yes  "mengaktifkan fiture web proxy"

    maximal-client-connections=1000
    maximal-server-connections=1000


    IP Web-Proxy :
    /ip web-proxy set enabled=yes "mengaktifkan web proxy (IP proxy dan IP web-proxy tergantung versi mikrotik"

    set src-address=0.0.0.0 "alamat yang kita gunakan untuk koneksi ke parent proxy (default-nya 0.0.0.0)"

    set port=8080 "port yang digunakan untuk web proxy"

    set hostname="proxy.andisyam.web.id" "nama hostname untuk web proxy (optional)"

    set transparent-proxy=yes "mengaktifkan transparent proxy"

    set parent-proxy=0.0.0.0 "sesuaikan jika sobat ingin menggunakan parent proxy (optional)"

    set cache-administrator="syam_u@bismillah.com" "email admin yang akan dikirim jika proxy mengalami error"

    set max-object-size=8192KiB "ukuran maksimal file yang akan disimpan sebagai cache (default=4096kilobytes)"

    set cache-drive=system "drive tempat menyimpan cache"

    set max-cache-size=unlimited "ukuran maksimal harddisk yang akan dipakai menyimpan file cache (4 kali total RAM atau unlimited)"

    set max-ram-cache-size=unlimited "maksimal ram yang digunakan untuk cache"


Membuat rule NAT untuk transparent proxy, dimana me-redirect port web ke transparent proxy yaitu mengarahkan semua trafik yang menuju port 80, 3128 dan 8000 kita belokkan menuju port 8080, yaitu port Web-Proxy :

/ip firewall nat add chain-dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 "redirect port 80 ke port 8080 proxy server"

/ip firewall nat add chain-dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080

/ip firewall nat add chain-dstnat protocol=tcp dst-port=8000 action=redirect to-ports=8080


Memeriksa hasil konfigurasi NAT :

[admin@andisyam.web.id] > /ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0  chain=srcnat out-interface=public action=masquerade
1 chain=dstnat in-interface=local src-address=192.168.0.0/24 protocol=tcp dst-port=80 action=redirect to-ports=3128

Untuk melihat hasil konfigurasi web-proxy :

/ip web-proxy print

Monitoring kinerja web-proxy :

/ip web-proxy monitor

Nah sobat sampai disini kita sudah dapat membuat transprent proxy kang . Perlu diketahui untuk pertama kalinya memasang proxy client tidak dapat mengakses sementara web yang dituju, hal ini disebabkan proxy akan me-request ke internet untuk men-cache permintaan pertama kalinya yang berasal dari client. pada umunya tidak berlangsung lama, tergantung koneksi sobat. Semoga artikel ini bermanfaat
 
Share this article :

0 comments:

Post a Comment

Popular Posts

Labels

Powered by Blogger.

Contact Form

Name

Email *

Message *

ads

Slider[Style1]

Recent

Ads Columns

Style5

Recent Posts

Style2

Style3[OneLeft]

Comments

Style3[OneRight]

Featured Posts

Style4

Video Of Day

Links

Welcome Guys

Followers

comments

Random

Videos News

Latest News

Posts List News

Páginas

Carousel News

Flicker Images

 
Support : mang acew | kangmui | Muin
Copyright © 2014. kangmuin_blog - All Rights Reserved
Template Created by kangmuin_blog Published by kangmuin
Proudly powered by Blogger